miércoles, 25 de diciembre de 2013

Instalación de Wacom Intuos CTL-480 en Ubuntu/Mint

Bueno, hace poco tiempo me quedé sin mi Wacom Bamboo debido a un accidente, y tuve que comprarme una nueva. No encontré la Bamboo y me compré una Intuos CTL-480 (también llamada Creative Pen). La verdad está bastante bien, en Windows ningún problema al instalarla, peeeeeero en Linux ya es otra cosa. Aún no han sido incorporados sus drivers en los Linux actuales, será porque es demasiado nueva y estos han salido hace poco.



Pero bueno, respecto a la instalación en Ubuntu/Mint...primero intenté instalarla en Ubuntu Studio 12.04, pero me dio problema pues necesitaba actualizar el kernel y con ello, me acabó perjudicando el tema del driver privativo de la tarjeta gráfica (lo cual me molestaba para el tema del 3d y videojuegos), así que decidí probar la última versión de Mint que le tenía ganas y aunque aún no le he instalado juegos, confío en lo que he léido de que los últimos drivers libres dan bastante de sí con el tema de la aceleración 3d. Aclaro, esto debido a que mi sobremesa tiene 4 años y una ATI/AMD de gráfica antigüilla ya, de ahí el problema, quienes tengáis una AMD Radeon HD 5000 o superior, o nvidia moderna, imagino que no deberíais tener este problema.

Ahora que ya la tengo instalada en Mint, funciona estupendamente. La solución me la encontré aquí:

En caso de que uséis Ubuntu 12.04 o Mint 13, o cualquier otro derivado cuyo kernel sea inferior a la versión 3.7, primero deberéis actualizar (y, ATENCIÓN, aquí es donde puede pasaros lo mismo que a mí con el driver privativo, así que si lo hacéis, por vuestra propia cuenta y riesgo) de la gráfica, con los siguientes comandos en Terminal:

sudo apt-get update
sudo apt-get install linux-image-generic-lts-raring linux-headers-generic-lts-raring

Reiniciáis y ya tenéis el nuevo kernel instalado. No conectéis aún la tableta.

Creáis una carpeta donde meteréis el módulo y sus parches para hacer funcionar nuestra tableta:

mkdir wacom; cd wacom

Descargáis y descomprimís el paquete que contiene dicho módulo:

wget http://sourceforge.net/projects/linuxwacom/files/xf86-input-wacom/input-wacom/input-wacom-0.19.1.tar.bz2

tar xjf input-wacom-0.19.1.tar.bz2

cd input-wacom-0.19.1/

Se descargan los parches y se aplican:

wget http://sourceforge.net/p/linuxwacom/mailman/attachment/CANRwn3Q5s_6jM3n7CBwuPfzmLJs5W89rPdkXYfN2kBRYL%3DkueA%40mail.gmail.com/1/ \
 -O patch1.patch

wget http://sourceforge.net/p/linuxwacom/mailman/attachment/CANRwn3Q5s_6jM3n7CBwuPfzmLJs5W89rPdkXYfN2kBRYL%3DkueA%40mail.gmail.com/2/ \
 -O patch2.patch

patch -p1 < patch1.patch

patch -p1 < patch2.patch
 
Se compila el módulo:
 
./configure
 
Se carga el módulo:
 
sudo insmod 3.7/wacom_w8001.ko
sudo insmod 3.7/wacom.ko
 
Y ahora sí conectamos la tableta y probamos.
Si funciona, aplicamos los siguientes comandos para que ya se carguen automáticamente cada vez que conectemos la tableta:
 

sudo cp 3.7/wacom_w8001.ko \
/lib/modules/`uname -r`/kernel/drivers/input/touchscreen/
 
 sudo cp 3.7/wacom.ko \
/lib/modules/`uname -r`/kernel/drivers/input/tablet/
 
 sudo depmod -a
 
 
Y fin. Ya debería funcionaros.  Si queréis, reiniciáis y comprobáis.